Events Planner Logo
Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

PHP Compatibility

Chris — Aug 16, 2017 02:34PM MDT

Is Events Planner compatible with PHP 7


2 Community Answers

Abel - Aug 16, 2017 at 08:08PM MDT

WP Events Planner Agent

Hi Chris.

I will do some extensive testing in the next few months. If you look at https://wordpress.org/about/stats/, notice how less than 15% of WordPress installs are on PHP 7. I am concentrating on 5.3 – 5.6 currently.

Thanks, Abel

rated : 0 Up Down

Ben - Nov 28, 2018 at 06:35PM MST

Well, it looks like this plugin has been well and truly abandoned and is no longer being supported, despite promises of it being re-written 'using new technologies', almost 2 years ago. This is all very disappointing, especially as I paid Abel to add some custom functionality. He is not even responding to personal messages.

In his last blog post, Abel talked about making the new 'major' version having PHP 5.4 as the minimum requirement. As I'm sure you are all aware, PHP 5.6 and PHP 7.0 are being depreciated in December and will no longer be supported, including no further security patches if vulnerabilites are discovered. This will leave sites open to being hacked and therefore, there is no choice but to upgrade to a minimum of PHP 7.1.

I'm not sure what version the last realese of EPP was but I'm using 2.1.0 and having tested it, it seems to work on PHP 7.0 (not fully tested), but not beyond this.

I haven't found any alternative plugin or even SaaS that provides te same functionality or meets our needs (and trust me, I've looked!).
So, what do we do? Give up on it or pay a developer to make it compatible with the latest versions of PHP? Or even commission a new plugin that retains the same feature set as EPP? Would be interested in your thoughts on where to go from here. Would anyone be interested in collaborating on an upgrade or new plugin?

rated : 0 Up Down

Post Your Public Answer